Win7 安装node更高版本的解决办法

小豆苗 1年前 ⋅ 2975 阅读

今天遇到一个问题:error commander@9.0.0: The engine "node" is incompatible with this module. Expected version "^12.20.0 || >=14".  要求node要么指定12.20.0版本,或者大于等于14的版本。

而我的电脑是win7的,目前win7支持的node最高版本是13.14,那怎么办呢?

解决办法就是安装指定的版本(12.20.0)或者大于14的版本,win7如果按照13.14以上的版本,是无法安装的。

1. 下载地址:https://nodejs.org/zh-cn/download/releases/

从这个地方下载14.15.3版本,记得选择32位或64位的7z或者zip的版本。

2. 将下载的包,解压覆盖到原来node安装的目录。

3. 覆盖之后使用node -v时会提示win7版本过低,我们需要指定一条语句

set NODE_SKIP_PLATFORM_CHECK=1

注意:每次关闭cmd之后都要重新输入set NODE_SKIP_PLATFORM_CHECK=1

每次关闭cmd之后都要重新输入set NODE_SKIP_PLATFORM_CHECK=1

每次关闭cmd之后都要重新输入set NODE_SKIP_PLATFORM_CHECK=1

重要的事情说三遍。

 

4 下一步安装vue-cli 这里我安装的是指定版本号3.12.0可自行修改

npm install -g @vue/cli@3.12.0 //安装指定版本号

npm install -g @vue/cli   //安装最新版本

npm install -g vue-cli       //安装2.9.6版本

继续安装webpack 这里我也是安装了指定版本号3.6.0,因为脚手架2依赖这个版本

npm install webpack@3.6.0 -g //指定3.6.0版本

npm install webpack -g //安装最新版本

最后测试一下:

vue create demon     //(demon)是项目名字

// 创建好之后我们按照提示 cd进入然后3.0的脚手架是运行命令是 
npm run serve 

// 如果你是用2.0脚手架运行命令
npm run dev

大功告成。


全部评论: 0

    我有话说: